Cowboy's Wiki:Kartenwerkstatt/Hilfe/Erstellung von Bahnkarten auf Basis von OpenStreetMap

Aus Cowboy's Wiki
Wechseln zu: Navigation, Suche

Kartenwerkstatt

Aktuelle Bearbeitungen
 

Kartenwünsche

„Ich hätte gerne folgende Karte …“
 

Schaufenster/Blog

Galerie und Statistik – Ideen und Kurioses
 

Archiv

 

Hilfe

Für Kartografen
World Map Icon ?.svg

Karten für Cowboy's Wiki selbst erstellen

Die Hilfeseiten der Kartenwerkstatt bieten grundlegende Tipps und Vorschriften zur Selbsterstellung von Karten. Sie richten sich an alle Wikianer, die einem Artikel eine selbst gezeichnete oder ergänzte Karte hinzufügen möchten.

Es wird erklärt

  • wie eine gute Karte aussehen sollte,
  • mit welchen Programmen man sie erstellen kann,
  • wie man an freie Geodaten herankommt,
  • in welchen Formaten Karten abgespeichert werden können und
  • wie Karten in Artikel eingebunden werden.


Falls du Fragen zum Thema Karten und Kartenerstellung hast, dann stelle sie am besten auf der Diskussionsseite der Kartenwerkstatt.

Karte der Bahnstrecke Mönchengladbach–Düsseldorf.png

Bahnstreckenartikel werden durch eine kartographische Darstellung der Streckenführung ganz erheblich aufgewertet. Meist werden dazu frei zugängliche Rasterdaten (Demis, maps-for-free) für den Hintergrund verwendet, über die dann mittels eines Zeichenprogramms die Strecke hinzugezeichnet wird. Durch den zügigen Ausbau frei verfügbarer Daten in OpenStreetMap ist es mittlerweile aber auch möglich geworden, auf (relativ) einfache Weise Karten mit hoher Informationsdichte und auf Vektordatenbasis zu erzeugen (siehe nebenstehendes Beispiel).

Hier soll deshalb den Interessierten ein Leitfaden in die Hand gegeben werden, wie sie solche Karten selbst erstellen können.

Übrigens können selbstverständlich auch andere Karten, wie Ortskarten oder Straßenpläne, auf dieser Basis erstellt werden. Der grundlegende Ablauf bleibt bis zum Kapitel „Karteninhalt erstellen“ zunächst im Wesentlichen derselbe, bevor dann die für die jeweilige Karte spezifischen Elemente (Ortsnamen, Straßennummern, Sehenswürdigkeiten im Ort usw.) mit aufgenommen werden.

Die Beschreibung hier basiert auf dem Grafikprogramm Adobe Illustrator. Die grundsätzliche Vorgehensweise kann aber auf andere Grafikprogramme, wie z. B. CorelDraw oder FreeHand übertragen werden. Die freie Software Inkscape hat sich hingegen leider als (noch) nicht besonders gut geeignet erwiesen (siehe hier) – mit leichten Abstrichen funktioniert die Vorgehensweise aber ebenso (Beispiel).

OSM-Datenexport

OpenStreetMap bietet einen Export-Reiter an, über den die kartographischen Daten auch ohne tiefere Kenntnis der OSM-internen Datenformate abgerufen werden können. Als Export-Format sollte PDF gewählt werden, da die Alternative SVG extrem große, und somit nicht mehr handhabbare Dateien erzeugt. Danach den gewünschten Kartenbereich markieren und einen nicht zu großen Maßstab angeben (etwa 1:100.000 bis 1:250.000 – ein größerer Maßstab bedeutet größere Datenmengen und mehr Details, die später nur wieder mühsam entfernt werden müssen), bevor die PDF-Datei dann endgültig angefordert und auf der eigenen Festplatte abgespeichert wird.

Vorbereitung des Arbeitsbereichs im Grafikprogramm

Im Endeffekt soll es im Grafikprogramm die folgenden Zeichenebenen (Layer) geben, die wir auch gleich anlegen:

  • „Strecke“ (der oberste Layer): alles, was nicht aus OSM stammt, also die darzustellende Bahnstrecke mit ihren Bahnhöfen, den Beschriftungen und sonstigen Elementen, wie z. B. Maßstabsleiste, Orientierungskarte usw.
  • „Bahnen“: alle sonstigen Bahnstrecken (die wir aus der OSM-Grundlage übernehmen werden)
  • „Abdecker“: ein Zwischenlayer, der dazu dient, die OSM-Basiskarte etwas „herunterzudimmen“
  • „OSM“ (der unterste Layer): die OSM-Kartendaten aus der abgespeicherten PDF-Datei

Einlesen der OSM-Daten

Hierzu über Datei → Platzieren/File → Place die abgespeicherte Datei auswählen und im Layer „OSM“ ablegen.

Aus irgendwelchen Gründen liegen über der eigentlichen Karte in der PDF-Datei noch eine ganze Reihe an Begrenzungsrechtecken, die den „Durchblick“ auf die eigentliche Karte verhindern. Diese löschen wir weg, indem wir mit dem „weißen Pfeil“-Werkzeug ganz knapp über einer der vier Begrenzungsecken ein Auswahlrechteck aufspannen. Das Auswahlrechteck sollte möglichst wirklich nur den Eckpunkt umgreifen, da ansonsten weitere Elemente ungewollt mit gelöscht werden. Wenn diese Auswahl erfolgt ist, zweimal die <Entf>-Taste drücken (das erste Drücken löscht nur den Eckpunkt, das zweite dann die daran hängenden Begrenzungsrechtecke).

Falls nach dieser Aktion noch die ockerfarbene Hintergrundfläche übriggeblieben sein sollte, diese auch weglöschen.

Um am Schluss nicht den gesamten OSM-Kartenbereich als PNG zu exportieren, begrenzen wir dann zunächst einmal den Arbeitsbereich mit dem Artboard-Werkzeug (kann mittels <Ctrl-O> (= gleichzeitig die Tasten <Strg> und <O> [der Buchstabe 'O'] drücken) auf den gewünschten Ausschnitt.

(Anmerkung: In den Illustrator-Versionen bis CS3 wurde der Kartenbereich noch anders begrenzt. Hier zuerst ein Rechteck mit dem Rectangle-Tool – einfach auf die Taste <M> drücken – über dem gewünschten Bereich aufziehen und weiterhin markiert belassen, dann Object → Crop Area → Make auswählen ...und der Exportbereich ist festgelegt. Wenn man ihn wieder auflösen will: Object → Crop Area → Release.)

Mittels <Strg-0> [die Zahl 0] können wir ab diesem Zeitpunkt auch immer wieder auf genau diesen Ausschnitt zoomen.

Bahnstrecken in einen eigenen Layer kopieren

Als nächstes selektieren wir die Bahnstrecken aus dem OSM-Layer. Dazu eine der Bahnstrecken mit dem „weißen Pfeil“-Werkzeug anklicken und dann Auswahl → Gleich → Stil/Select → Same → Appearance wählen. Zum Kopieren dieser Strecken jetzt <Ctrl-C> drücken.

In der Layerleiste nun den Layer „Bahnen“ anwählen und, wenn dies erfolgt ist, <Ctrl-F> drücken. Die Bahnstrecken werden somit genau an derselben Position in den Layer „Bahnen“ hineinkopiert, von der man sie im Layer „OSM“ wegkopiert hat (mit <Ctrl-V> wären sie leicht versetzt hineinkopiert worden).

Jetzt diesen Linien noch eine etwas größere Linienstärke verpassen, damit sie dann in der Endkarte auch wirklich gut erkennbar sind.

Den Layer „Bahnen“ danach verriegeln, damit die folgenden Bearbeitungen sich auf diesen nicht mehr auswirken können.

OSM-Daten nachbearbeiten

Als nächstes müssen aus dem Layer „OSM“ ungewünschte Elemente entfernt werden. Dies sind alle in der Karte enthaltenen Texte und eine Reihe von Flächensignaturen, wie bebaute Flächen (in grau), Ackerflächen (ocker), Kiesflächen (dunkelgrau), Gewerbeflächen (rötlich), Sonderflächen (auch rötlich, aber etwas dunkler) usw... Was an Flächen nur übrig bleiben sollte, sind alle möglichen Varianten von Grünflächen (in den unterschiedlichsten Grüntönen) und Wasserflächen (hellblau).

Zunächst das Löschen der Flächen: leider muss dieses für jede der Flächen-Kategorien einzeln durchgeführt werden – und zwar indem (wie bei den Bahnstrecken) eines der Objekte mit dem weißen Pfeil ausgewählt, dann Auswahl → Gleich → Stil/Select → Same → Appearance aus dem Menu angeklickt und schließlich (wenn die Objekte als Gruppe ausgewählt sind) einfach die <Entf>-Taste gedrückt wird.

Das Löschen der Texte erfolgt genau nach demselben Schema, allerdings muss man hier aufpassen, da diese jeweils zweimal in der OSM-Karte existieren: einmal als Text an sich und einmal zur Darstellung der Textkonturen. Also auch hier bei allen vorkommenden Textobjekten (Ortsnamen, Autobahnausfahrten, Straßennummern ...) jeweils erstmal einen der Repräsentanten der Kategorie mit dem weißen Pfeil auswählen, Auswahl → Gleich → Stil/Select → Same → Appearance wählen und dann die <Entf>-Taste drücken.

Die Nachbearbeitung des OSM-Layers ist hiermit aber noch nicht abgeschlossen: Als nächstes sollten alle Grünflächen noch denselben Farbton erhalten – also unabhängig davon, ob sie nun einen Wald, einen Forst, eine Obstanbaufläche, einen Park, einen Friedhof oder sonstwas darstellen.

Die Auswahl solcher Objekt in ihrer Gesamtheit sollte mittlerweile ja vertraut sein. Wenn man die jeweilige Gruppe selektiert hat, ist in der Werkzeugleiste die Pipette auszuwählen und damit die Farbe einer der hellen Grünflächen (ich glaube, es handelt sich dabei um den „einfachen Wald“, auf jeden Fall meine ich damit die Flächen in dem typischen Hellgrün, die die OSM-Karten außerhalb der Städte meist dominieren) abzugreifen. Somit erhalten alle zuvor mittels Select ausgewählten Flächen ebenfalls genau diesen Grünton. Dasselbe dann für alle anderen umzufärbenden Grünflächenkategorien wiederholen.

Die Bearbeitung des Layers „OSM“ ist damit abgeschlossen, weshalb er dann auch verriegelt werden kann.

OSM-Karte mittels Zwischenlayer abdimmen

Damit der Layer „OSM“ in der endgültigen Karte nicht zu dominant erscheint, soll dieser nun etwas „abgedimmt“ werden. Hierzu wird im Layer „Abdecker“ einfach eine weiße Fläche über den gesamten Arbeitsbereich aufgezogen und deren Transparenz in der entsprechenden Einstellungsbox (falls diese noch nicht geöffnet ist, ist sie über Fenster → Transparenz/Windows → Transpearency zu erreichen) auf etwa 10 Prozent Deckkraft eingestellt. Schon sieht der darunter liegende Layer „OSM“ etwas unaufdringlicher aus...

Auch dieser Layer kann nun verriegelt werden.

Karteninhalt erstellen

Nach all diesen Vorbereitungsmaßnahmen kann es jetzt an die Erstellung des eigentlichen Karteninhalts gehen. Diese erfolgt im Layer „Strecke“, weshalb wir diesen nun zur Bearbeitung anwählen. Die hier durchzuführenden Schritte sind:

  • Als erstes ist der Streckenverlauf mit dem Zeichenfeder-Werkzeug abzudigitalisieren (ich rate hier davon ab, die entsprechenden Streckenstücke aus dem Layer „Bahnen“ zu übernehmen – dies artet nur in einer reinen Sisyphos-Arbeit aus und erbringt am Ende keinerlei besseres Ergebnis).
  • Dann sind die Bahnhöfe und Haltepunkte mit dem Ellipsen-Werkzeug (<Shift>-Taste gedrückt halten und es entstehen beim Aufziehen saubere Kreise) anzulegen. Wenn erst einmal ein solches Symbol erstellt ist, dieses danach einfach kopieren und neu einfügen. Somit ist gewährleistet, dass diese Symbole gleich groß und mit denselben Eigenschaften versehen bleiben.
  • Als nächstes folgen die Beschriftungen. Auch hier am besten erstmal einen Prototypen erstellen, der dann immer wieder kopiert werden kann. Hierzu einen kurzen Text („Abc“) eintippen, dann eine weiße Fläche erzeugen und diese genau so über den Text legen, dass dieser gerademal gut abgedeckt ist. Danach die Fläche hinter den Text legen (Objekt → Anordnen → Nach hinten stellen/Object → Arrange → Send to Back) und mittels der bereits bekannten Transparency-Eigenschaft leicht durchsichtig machen (Deckkraft ca. 30 Prozent). Jetzt den rechten Rand dieser Fläche relativ weit nach rechts hinausziehen und dann den Text zusammen mit der gerade erzeugten Freistellfläche gruppieren (Objekt → Gruppieren/Object → Group).
    Wozu das Ganze? Jetzt können wir diese Objektgruppe einfach kopieren, den Text bearbeiten und – da der rechte Rand der Freistellfläche noch leicht erreicht werden kann, ohne mit dem Text selbst in Konflikt zu kommen – die rechte Begrenzung der Freistellfläche einfach mit dem weißen Pfeil auf die tatsächliche Textlänge zurückziehen.
    Jetzt diese Objektgruppe noch an die richtige Stelle schieben (jetzt aber mit dem schwarzen Pfeil, sonst erwischt man nicht die Gruppe als Ganzes, sondern man verschiebt nur den obenaufliegenden Text allein), und der entsprechende Bahnhof ist beschriftet.
  • Schließlich erfolgt noch die Endausgestaltung der Karte. Jetzt können ganz nach Gusto noch Maßstab, Orientierungskarte, Begrenzungsrahmen oder sonstige gewünschte Elemente eingefügt werden.

Falls gewünscht, steht hier für die Übernahme von Farbwerten, Symbolen, Linienbreiten usw. auch die svg-Referenzdatei zu obiger Karte zur Verfügung.

Die Karte ist nun fertig. Speichern nicht vergessen!

PNG-Export durchführen und auf Commons hochladen

Jetzt möchte man sein Meisterwerk ja auch veröffentlichen. Dateiformat der Wahl ist hierbei PNG. Um ein solches zu erzeugen, auf Datei → Exportieren/File → Export gehen und die ganzen Abfragefenster abarbeiten. Aufpassen, dass nicht „All“ ausgewählt ist, da sonst nicht nur der gewünschte Kartenausschnitt exportiert wird, sondern der gesamte Kartenbereich der OSM-Basiskarte. Hier also in jedem Fall "Range" auswählen. Bei der Auflösung muss man dann meist ein wenig herumprobieren: zunächst mal mit 72dpi anfangen, dann schauen, wie breit und hoch der Export in Pixeln geworden ist und ob die Auflösung noch zu gering oder bereits übertrieben ist. Danach nochmal einen Export mit entsprechend höherer bzw. niedrigerer Auflösung durchführen.

Schließlich muss die Karte noch auf die Commons hochgeladen werden. Hierbei als Lizenzbaustein unbedingt {{OpenStreetMap}} angeben, da von OSM eine ganz bestimmte Lizensierung gefordert wird, die somit abgedeckt ist. Als Kategorie sollte zumindest Category:Rail transport maps of Germany (bzw. die jeweilige Entsprechung, falls die Karte eine Bahnstrecke außerhalb von Deutschland wiedergibt) angegeben werden.

Wenn die Karte dann hochgeladen ist, das Ganze am besten auch in der Kartenwerkstatt einstellen und sich loben lassen! ;-)

Tipps und Tricks für Inkscape

Nutzt man Inkscape anstelle von Adobe Illustrator, lassen sich die meisten Dinge inzwischen ebenso erledigen. Einige Bearbeitungsschritte sind aber zunächst weniger intuitiv.

Wie lassen sich gleichartige Elemente arbeitssparend markieren?
Das geht wie folgt:

  • Musterelement markieren (z.B. ein Bahnstreckenelement)
  • "Bearbeiten > XML-Editor ..." auswählen (auch Shift + Ctrl + X)
  • im XML-Editor-Fenster das Attribut "style" auswählen (anclicken)
  • unten rechts (im Textkasten) den gesamten Text markieren (sowas wie "opacity:0.79844965;fill:none;stroke:#550000;stroke-width:2;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-opacity:1") und kopieren
  • "Bearbeiten > Suchen ..." auswählen (auch Ctrl + F)
  • im Suchfenster ins Feld "Stil" den kopierten Text einsetzen
  • "Suchen" auswählen

Dann sind alle gleichartigen Elemente markiert und du kannst sie gruppieren, löschen, in der Farbe verändern, etc. Gerade am Anfang, wenn man viele unnötige Elemente aus den OSM-Rohdaten löschen muss, ist das eine sehr wichtige Funktion.

Wie lässt sich eine Beschriftung besser lesen?
Wenn man Texte (z.B. Bahnhofsnamen) vor dem Kartenhintergrund hervorheben möchte, hat es sich bewährt, das (schwarz geschriebene) Wort zu duplizieren und die Kopie in weißer Schrift ("Füllung") und mit weißer Kontur (bitte die "Breite" der Kontur noch vergrößern, z.B. auf 4 px) hinter das schwarze Original zu verschieben. Dann ist jeder Buchstabe weiß umrandet und vor einem bunten Hintergrund besser lesbar.

Viel Spaß beim Basteln und Ausprobieren!

Beispiele

Die folgende Auswahl an Karten wurde auf dieser Anleitung aufbauend erstellt. Wie man sieht: sich einfach mal an die Sache ranzuwagen, lohnt sich!